hs-plugins runtime error with GHC 6.6: index out of range

Adam Megacz adam at megacz.com
Sun Jan 14 21:42:23 EST 2007

dons at cse.unsw.edu.au (Donald Bruce Stewart) writes:
> 3 issues break hs-plugins in 6.6, and I'm working on them:
>     a) AltData.Typeable is obsolete, now that Typeable handles dynamic code properly
>     b) the .hi file format changed, so the hs-plugins .hi parser needs to as wel
>     c) the package format changed a little bit
> Should be about 1 days work. 

Hi, thanks for posting about this -- I thought I was going crazy
trying to figure out why dependencies weren't getting resolved.

Has anybody had a chance to resolve/update this?  This appears to be
the last thing I need to get HSP working.

  - a

PGP/GPG: 5C9F F366 C9CF 2145 E770  B1B8 EFB1 462D A146 C380

More information about the Libraries mailing list