darcs patch: Add equating p x y = p x == p y

Jon Fairbairn jon.fairbairn at cl.cam.ac.uk
Fri Oct 20 07:19:36 EDT 2006

On 2006-10-20 at 11:34BST Malcolm Wallace wrote:
> I would like to propose a new module for functions like this, which are
> in some sense "purely" functional, that is, they do not involve any data
> structure at all, just functions.  Other examples would be
>     const
>     id
>     flip
>     (.)
>     ($)
>     ($!)
> Any suggestions for a good name for such a module?  Data.Function does
> not sound right to my ears.

Control.Combinators? Such general beasts as mapFst, mapSnd
and >< from Data.Graph.Inductive.Query.Monad could go in
there, as could other pair handling combinators like (f <&>
g) x = (f x, g x)

They don't do much in the way of contolling flow, so one
might argue that they should just be Combinators.


Jón Fairbairn                              Jon.Fairbairn at cl.cam.ac.uk

More information about the Libraries mailing list