base libraries

Duncan Coutts duncan.coutts at
Fri Nov 24 06:23:54 EST 2006

On Fri, 2006-11-24 at 12:18 +0300, Bulat Ziganshin wrote:

> alternative solution - continue to include fps 0.8 in Base lib, and
> upgrade it to 0.9 in 6.8, will mean a much more serious
> incompatibility when switching to 6.8. plus, it will make impossible
> using of fps 0.9 in about year, until 6.8 arrives
> Don's solution - include fps 0.9 as part of 6.6.1 Base is even more
> terrible - it's 100% violation of these rules

Um, no it isn't. fps 0.9 is completely API compatible with the current
version. It's a performance upgrade only. We are not breaking API.

We knew this when we had it included in base, so we trimmed the API down
to make it supportable. We have no problem following the rules.


More information about the Libraries mailing list