Proposal: Adding Kleisli composition to Control.Monad

Donald Bruce Stewart dons at
Mon Nov 13 05:25:19 EST 2006

> On Mon, Nov 13, 2006 at 02:27:12PM +1100, Donald Bruce Stewart wrote:
> > I'm we're going to use this forever more, then a name more meaningful
> > than repeatM_ might be appropriate (personally, I have to check every
> > time whether it is replicate or repeat that is :: Int -> a -> [a]).
> now it will be three times easier to remember, as you only need to
> remember what one of repeat, repeatM, and repeatM_ do to easily
> determine what the other two do. standard naming conventions are very
> nice when they fit so well, as they do in this case.

Ok :)

I'll resubmit 'repeatM_' as a separate patch.

-- Don

More information about the Libraries mailing list