Names for small functions: just say no... Re: Data.List.join

isto isto.aho at
Fri Nov 10 14:01:13 EST 2006

pe, 2006-11-10 kello 12:51 -0500, Robert Dockins kirjoitti:
> The Haskell standard libraries are not, and have never been, a minimal basis 
> lacking redundancy.  Are you also opposed to the existence of
> Programmers find this concept useful and they name it.  This has been done 
> We should codify this idea.  This function should be in the standard libs.  I 
> personally don't much care what it's called.

And as was said, what's natural and intuitive differs from person
to person meaning IMO that it's better to support different ways of
doing and thinking things. Thus, both in the libs sounds fine.

br, Isto

More information about the Libraries mailing list