proposal: add 'unsafeCoerce'

kahl at kahl at
Fri Nov 10 09:38:55 EST 2006

Malcolm Wallace wrote:
 > Currently, all implementations provide either the 'unsafeCoerce' or
 > 'unsafeCoerce#' functions, but they live in implementation-specific
 > locations.  This proposal is to adopt the Haskell'98-compatible name
 > 'unsafeCoerce', and to add it to the standard base library package.
 > Suggested location: Data.Function.Unsafe?

I'd much prefer Data.Unsafe.

(It is a function, but has nothing to do with functions as data type.)


More information about the Libraries mailing list