Proposal: Adding on
Nils Anders Danielsson
nad at cs.chalmers.se
Tue Nov 7 13:25:12 EST 2006
On Mon, 06 Nov 2006, Nils Anders Danielsson <nad at cs.chalmers.se> wrote:
> Do we have a patch for equating fulfilling all the new requirements?
I have also just realised that equating is a bad name for this
function. To equate x and y does not mean to check whether they are
equal, but to treat them as equal, and that's not at all what the
function does. A better name might be equalityOn, as in
groupBy (equalityOn length). Or perhaps equalityOf.
In light of the above points I suggest that someone else creates a new
proposal for equating/equalityOn/whatever, so that it can be discussed
More information about the Libraries