darcs patch: add Data.Set.notMember and Data.Map.notMember

Christian Maeder maeder at tzi.de
Mon Mar 13 05:25:37 EST 2006

Cale Gibbard wrote:
>> I don't like notElem either
>>> * quite useful for cleaning up guards:
>>> f x | not (x `Set.member` map) && foo = ...
>>> is hard to read.

I think the plain application "not (Set.member x map) && foo" is more 
appropriate for a programming language like haskell with a somewhat 
limited support of mathematical notations (i.e. not postfix applications).

> Although I'd normally agree with negated versions of things being
> somewhat redundant, the infix version here is rather important, since
> one often wants the code to look the same way as the mathematics. The
> symbols \in and \not\in are both usually written infix, and that's not
> going to change soon. 

latex does not have to consider precedences and the latex sources also 
look much less nice than the final printed version.


More information about the Libraries mailing list