Library name choice for network accept loop module under
Donald Bruce Stewart
dons at cse.unsw.edu.au
Sat Dec 9 10:27:56 EST 2006
> I am working on a library module to implement a network accept loop
> with graceful shutdown. (See http://code.catdancer.ws/acceptloop/)
> This code is tricky to get right, so if I am successful, it will be
> useful to projects such as web or database servers which accept
> network connections and would like to be able to restart gracefully
> without dropping or losing connections.
> Is "Network.AcceptLoop" a good name for this module in the
> hierarchical library namespace?
I'd suggest not using CamelCase names in modules -- there are a few in
the base libs, but not many. So
perhaps. Accept (Loop) doesn't seem terribly intuitive, perhaps something like:
or something similar, emphasising the non-dropping aspect?
Thanks for contributing this!
More information about the Libraries