"FastPackedString" considered harmful

Donald Bruce Stewart dons at cse.unsw.edu.au
Wed Apr 19 23:26:27 EDT 2006

On the topic of a good name for FPS, I think its fairly widely
considered that a packed byte "string" shouldn't be considered a String,
and thus FastPackedString is a potentially confusing misnomer.
It was always meant as a working title until something replaced
Data.PackedString anyway.

If this library is to be imported into the base libraries, along with
future PackedString.Unicode and so on, layers on top, we should probably
get the name right now.

I'm disinclined to call it a ByteArray module -- it doesn't really offer
array-like operations. And its got nothing much to do with the other
Array.* stuff.

Instead, how about: Data.ByteString  (with a connotation of IntMap) ?

That seems to suggest both the stringy-ness of the api, but also the
restriction to bytes.

-- Don

More information about the Libraries mailing list