David Owen d_w_o at
Fri Mar 4 14:20:45 EST 2005

Hi all,

I have recently downloaded and installed Gtk2Hs but am having problems 
running the sample programs.

I am most interested in getting the TestEmbedMoz program working.  However 
when I try to compile it (either using make or ghc on the command line) it 
says that the interface file for MozEmbed does not exist (cannot find 
interface file for Graphics.UI.Gtk.MozEmbed).  I have tried it using both 
2.4 and 2.6 of the Windows versions of Gtk+ and the corresponding Gtk2Hs 
packages and neither seem to provide the file.  I have also built the 
packages from source and tried to compile but to no avail.  Maybe I need to 
do something wlse with the MozEmbed package file (?).  Mozilla 1.4 or 
greater is installed as needed.

My second problem is running other test programs that have successfully 
compiled.  For example the ButtonBox when I run it gives an "Entry Point Not 
Found" error, details: "The procedure entry point 
libiconv_set_relocation_prefix could not be located in the dynamic link 
library iconv.dll".  I've tried reinstalling Gtk+ and GtkHs a few times but 
it hasn't helped.

Any help with either problem would be appreciated.  I've looked at the Gtk 
FAQs but didn't see any answers (unless i missed them!).

regards all


More information about the Libraries mailing list