Cabal and Tool Dependencies

Brian Smith brianlsmith at
Sun Jul 10 22:56:01 EDT 2005

1. How can I tell what tool dependencies a package has? For example, how can 
I tell from a .cabal package that Happy 1.14 or later, or Alex 2.0 is 
required for the package to build properly? I am making a simple tool that 
uses .cabal files to build programs and I would like to be able to say "This 
package requires Happy 1.14 to be installed" upon loading the .cabal file 
(before the user runs "./Setup.hs build").
 2. Is it possible to register binary (executable) packages? For example, I 
would like to "register" Happy 1.15 with Cabal, somehow, so that Cabal knows 
what version of Happy I have installed. This would eliminate the need for me 
to use --with-happy, etc. when configuring.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Libraries mailing list