Cabal package descriptions
ijones at syntaxpolice.org
Thu Feb 10 11:24:53 EST 2005
Ross Paterson <ross at soi.city.ac.uk> writes:
> On Thu, Feb 10, 2005 at 07:55:01AM -0800, Isaac Jones wrote:
>> Ross Paterson <ross at soi.city.ac.uk> writes:
>> > (repeated) License and License-File should not be mutually exclusive.
>> > They're both useful, for different purposes. Perhaps License would
>> > be more accurately called License-Type.
>> I would like to make the license field required without being very
>> burdensome to the user; I feel like the license-file field is a bit
>> more burdensome and it's hard for me to justify making it required.
>> Do you still want to have a file as an option in the license-type
>> I guess we could make either/or required. What do you think about
>> what should be required?
> I'm not suggesting making License-File required; it's just that now
> the two fields conflict because they set the same field in the
> PackageDescription. I've suggesting that License (or Licence-Type)
> set a field that is an enumeration of constants, and Licence-File
> set a new FilePath field. I don't don't think either is required
> now. If you want to make Licence-Type required, I wouldn't mind.
That all sounds fine, then. I guess we should take the "OtherLicense"
option out of license type, add a licenseFile field, and make either /
Is anyone writing all this down? ;) 
 Just kidding, it's going in my ever-growing TODO list.
More information about the Libraries