cabal release (was: cabal experiences)

Ian Lynagh igloo at
Mon Dec 12 10:30:50 EST 2005

On Mon, Dec 12, 2005 at 03:14:09PM +0000, Duncan Coutts wrote:
> In Gentoo we made a decision to ship Cabal-1.1.3 with GHC 6.4.1. That is
> after installing GHC 6.4.1 we unregister Cabal-1.0 and install
> Cabal-1.1.3.

If all distributions and users are going to have to do this to get a
usable system[1] then it seems obvious to me that ghc should already
come this way. That it doesn't causes headaches for packagers IME.

[1] "usable system" is a bit strong, but I hope you understand what I

> I appreciate that we do not want to rush the next major release because
> there are new features that need to be got right. Perhaps we should
> think again about which Cabal version to include in the next GHC minor
> version, or perhaps to advise users in the release notes for GHC 6.4.2
> that it is highly recommended to upgrade to Cabal version x.y.

Incidentally, I would be happy if 6.4.2 was renamed 6.6 and newer cabal
added; I'm not asking for what is currently called 6.6 necessarily.

Or adding newer cabal to 6.4.2, against the policy, would suit me fine


More information about the Libraries mailing list