Cabal and c2hs

Dominic Steinitz dominic.steinitz at
Sat Apr 30 03:38:40 EDT 2005

I am trying to migrate some old code to cabal. It uses c2hs. Now I wasn't sure 
I had c2hs installed so I ran cabal anyway.

1. Why isn't configure telling me where c2hs is? It tells me where hsc2hs is!
2. Why is cabal telling me it can't find a source when the source is present?

Thanks, Dominic.

Here's ping.cabal:

Name:           Ping
Version:        0.0
License:        BSD3
Author:         Dominic Steinitz
Synopsis:       The Haskell equivalent of ping

Executable:     ping
Main-Is:        test.hs
Other-modules:  IP_ICMP.chs

When I run ./Setup configure, I didn't see any message saying whether c2hs was 
installed and when I run ./Setup build I get the following:

[dom at tility ping]$ ./Setup build
Preprocessing executables for Ping-0.0...
can't find source for IP_ICMP.chs in ["."]

But the source is there:

[dom at tility ping]$ ls
codes.hs  dist/        ip_icmp.h  ping.cabal   Setup*    Setup.hs  test.hs
CVS/      IP_ICMP.chs  Makefile   ping.cabal~  Setup.hi  Setup.o

More information about the Libraries mailing list