DData revision

Christian Maeder maeder at tzi.de
Tue Mar 16 11:49:22 EST 2004

JP Bernardy wrote:
> A revision of DData.
> http://users.skynet.be/jyp/DData/doc

In Set, I find the name


unnecessary long.

Again, I suggest to omit toAscList (as it is the same as toList)
and to rename fromDistinctAscList to fromAscList and provide no extra 
treatment for ascending list with duplicates. (Maybe a linear nub 
variant can be provided elsewhere:  ... = map head . group)

Thus "Asc" could indicate unchecked variants and always means strongly 
ascending. (Therefore I suggested "mapAsc")


More information about the Libraries mailing list