Prelude function suggestions
Marcin 'Qrczak' Kowalczyk
qrczak at knm.org.pl
Wed Jul 28 10:40:20 EDT 2004
W liście z śro, 28-07-2004, godz. 14:11 +0200, Marcin 'Qrczak' Kowalczyk
napisał:
> I just wanted to name such functions for my language and they are called
> Split and Split1. I like the name split, as it's used in Python, Perl
> and Ruby; I don't like the name split1 but don't have anything better.
Or what about this:
splitSep - separators are between
splitEnd - separators are between, with an optional separator at the end
splitSeps - separators are between, many separators are permitted
splitEnd is a generalization of lines, it's equivalent to splitSep with
the last element removed if it's empty;
splitSeps is a generalization of words, it's equivalent to splitSep with
all empty elements removed.
Python's split is splitSep. Perl's and Ruby's are neither of these,
but I think that removing *all* trailing empty elements is not useful.
--
__("< Marcin Kowalczyk
\__/ qrczak at knm.org.pl
^^ http://qrnik.knm.org.pl/~qrczak/
More information about the Libraries
mailing list