Fri, 5 Sep 2003 16:02:21 +0100
> Now that RealWorld, formerly an implementation trick inside GHC, has
> become part of the public interface:
> stToIO :: ST RealWorld a -> IO a
> (to make stToIO sound), I think it needs a better name. The IO monad
> does not in fact give you exclusive access to the world, but to a
> region of the heap separate from those used by invocations of runST.
> (That's not all IO does, of course, but it's the relevant part for
> stToIO.) I propose IORegion.
Fine by me too.