Fri, 5 Sep 2003 14:54:55 +0100
Would be fine with me.
| -----Original Message-----
| From: firstname.lastname@example.org [mailto:email@example.com]
On Behalf Of Ross Paterson
| Sent: 05 September 2003 11:08
| To: firstname.lastname@example.org
| Subject: RealWorld
| Now that RealWorld, formerly an implementation trick inside GHC, has
| become part of the public interface:
| stToIO :: ST RealWorld a -> IO a
| (to make stToIO sound), I think it needs a better name. The IO monad
| does not in fact give you exclusive access to the world, but to a
| region of the heap separate from those used by invocations of runST.
| (That's not all IO does, of course, but it's the relevant part for
| stToIO.) I propose IORegion.
| Libraries mailing list