[jhc] Parsec -- Module not found

David Virebayre dav.vire+haskell at gmail.com
Tue Aug 10 04:08:07 EDT 2010


I've tried a small program that uses parsec, but I couldn't get it to compile :

david at pcdavid:/data/code/edimail$ jhc -C DecVersBL.hs
jhc -C DecVersBL.hs
jhc 0.7.6 (0.7.6-3)
Finding Dependencies...
Using Ho Cache: '/home/david/.jhc/cache'
DecVersBL               [DecVersBL.hs]
Error: Module not found: Text.ParserCombinators.Parsec
Error: Module not found: Text.ParserCombinators.Parsec.Char
Error: Module not found: Text.ParserCombinators.Parsec.Combinator

I've looked into /home/david/download/jhc-0.7.6/lib/ext/parsec.cabal,
exposed modules are Text.ParserCombinators.Parsec.xxxx, which is what
I tried to import.

Just in case, I've also tried the simpler names Text.Parsec, etc.

jhc --list-libraries does list parsec-

I've tried to find Parsec on the disk hoping it'd give me a clue about
what to import, but I only found
which doesn't help at all.

There must be something really stupid I'm missing here.

Help !


More information about the jhc mailing list