import chasing in hugs vs. runhugs

Gregory Wright
Sat, 29 Mar 2003 12:50:55 -0500


I've written a port file for hugs under Mac OS X using the darwinports
infrastructure. The port seems to work fine. I'm adding an option to
automatically load the School of Expression graphics files, and while
testing I noticed something I don't understand. I'd like to know if it's
a bug, or which manual page I should RTF.

I've modified the SOE graphics build so it builds under OS X with no
trouble, using Apple's X11. When I run the suggested tests using 
some work OK, but others fail:

bash> runhugs -Pgraphics-2.0.4/lib/x11: graphics-2.0.4/test/Tests.hs
runhugs: compileExpr: invalid module

The only modules that Tests.hs imports are GraphicsUtils (found in the 
-P path)
and Exception. In this case, the Exception module isn't found.

What's odd is that if I run the same thing interactively,

hugs -Pgraphics-2.0.4/lib/x11: graphics-2.0.4/test/Tests.hs

all of the modules are found successfully and I can run the tests.

If this is a known problem I can just annotate the port with a warning.

Thanks for your help.

Best Wishes,
Greg Wright