[HOpenGL] ghc-6.0.1 and OpenGL enabled
Wolfgang Thaller
wolfgang.thaller at gmx.net
Wed Oct 8 16:07:36 EDT 2003
Sven Panne wrote:
> (BTW, I'm not very happy with this name, any suggestions are highly
> appreciated.)
Sven Eric Panitz wrote:
> I do not really like the name 'matrixExcursion'. It is so technical a
> name. Since quite often the code passed to a matrixExcursion is
> in form of a do notation, I found the name locally quite appealing
> [...]
Yes I don't like matrixExcursion either. But "locally" seems to
general; the term "local" can mean too many things in a computer
program.
What about something like "saveMatrix"?
While not being perfect, It fits with saveServerState and
saveClientState, and it is easy to guess from the name that it has
something to do with pushMatrix and popMatrix.
Another remark:
I would like "saveAttrib" and "saveClientAttrib" even better than
save*State; While I agree that the save*State names are nicer by
themselves, saveAttrib and saveClientAttrib are closer
to the C "originals". I consider that very important.
Cheers,
Wolfgang
More information about the HOpenGL
mailing list