[Haskell] cabal-install and ghc compatibility

briand at aracnet.com briand at aracnet.com
Sun Mar 25 00:27:00 CET 2012


I've got ghc 7.2.2 installed.

trying to install cabal-install-0.10.2 results in:

Linking Setup ...
Configuring Cabal-
Setup: At least the following dependencies are missing:
base >=4 && <3 && >=2 && <5, unix >=2.0 && <2.5

Error during cabal-install bootstrap:
Configuring the Cabal package failed

Do I need to be using development versions of cabal/cabal-install if I'm also going to be using newer versions of ghc ?

How do I know which version of cabal are compatible with which versions of ghc without trying to install it and seeing if it works ?

Thank you,


More information about the Haskell mailing list