[Haskell] Re: ANNOUNCE: GHC version 6.12.1

Duncan Coutts duncan.coutts at googlemail.com
Mon Dec 14 18:42:14 EST 2009

On Mon, 2009-12-14 at 22:49 +0100, Daniel Fischer wrote:
> Oh great, that's not what I expected:
> $ cabal install cabal-install
> cabal: This version of the cabal program is too old to work with ghc-6.12+.
> You will need to install the 'cabal-install' package version 0.8 or higher.
> If you still have an older ghc installed (eg 6.10.4), run:
> $ cabal install -w ghc-6.10.4 'cabal-install >= 0.8'
> $ cabal install -w ghc-6.10.3 'cabal-install >= 0.8'
> Resolving dependencies...
> cabal: There is no available version of cabal-install that satisfies >=0.8
> Oops, nothing higher than 0.6.4 on Hackage, even
> darcs.haskell.org/cabal-install is only version 0.7.5. 

Right, the cabal-install 0.8.x release will appear in due course.

It shouldn't be too long since I've already been using it for Hackage
regression testing of ghc-6.12.

> That seems to work, though, but I needed to manually install network, mtl and parsec 
> before bootstrap.sh ran.

Yes, the bootstrap needs updating to take account of the fact that those
packages are no longer shipped with ghc-6.12.


More information about the Haskell mailing list