[Haskell] Linking Multiple Versions of the Same Package

Duncan Coutts duncan.coutts at worc.ox.ac.uk
Mon Sep 1 08:41:36 EDT 2008

On Mon, 2008-09-01 at 02:58 -0700, Ashley Yakeley wrote:
> I tried doing this out of curiosity. Package B links to version 0.1 of 
> open-witness, while package C links to B and version 0.1.1 of open-witness.
> Cabal stopped me when doing "cabal configure" in C:
>    $ cabal configure
>    Configuring C-0.1...
>    Warning: This package indirectly depends on multiple versions of the same
>    package. This is highly likely to cause a compile failure.
>    package B-0.1 requires open-witness-0.1
>    package C-0.1 requires open-witness-0.1.1

It does not stop you. It's a warning.

The reason it warns is because almost every use of multiple versions of
a package is a mistake. We do not currently have a mechanism to see
which uses are deliberate or obviously safe so Cabal has to be


More information about the Haskell mailing list