[Haskell] Re: Trying to install binary-0.4

Duncan Coutts duncan.coutts at worc.ox.ac.uk
Mon Oct 15 17:56:11 EDT 2007

On Fri, 2007-10-12 at 01:27 +0200, Udo Stenzel wrote:
> Don Stewart wrote:
> > Since you're not using ghc 6.8, you should use binary 0.3 :)
> That was PC for "sorry, GHC 6.6 is no longer supported and don't even
> ask about 6.4"

As far as I can see, there's no good reason why binary, tar, etc cannot
work with ghc-6.4, 6.6 and 6.8. I've made it work for my zlib & iconv
libs just fine without too much cpp'ery.

So I'm going to try and fix binary, tar etc to work with all recent ghc.
Stay tuned.

Obviously it'll need the newest Cabal, but that works with all versions
of ghc back to 6.2, and it can be installed as user.


More information about the Haskell mailing list