[Haskell] Re: Trying to install binary-0.4

Brandon S. Allbery KF8NH allbery at ece.cmu.edu
Sun Oct 14 13:28:51 EDT 2007

On Oct 14, 2007, at 12:48 , Ian Lynagh wrote:

> On Sun, Oct 14, 2007 at 05:19:31PM +0200, Udo Stenzel wrote:
>> Ian Lynagh wrote:
>>> People interested in making it easy to use new versions of  
>>> packages with
>>> old compiler releases can make a small script that installs empty  
>>> Cabal
>>> packages called bytestring, containers, array, etc.
>> That completely misses the fact that bytestring cannot be  
>> upgraded, no
>> matter how many fake packages are available.
> Ah, you mean the problem is that it really does depend on some  
> change in
> bytestring (the internal API?), rather than just having a  
> dependency on
> the bytestring package?

I think dons has said that the latest bytestring depends on some GHC  
6.8 internals that can't reasonably be backported, so if you need the  
new bytestring API, you're kinda stuck.

brandon s. allbery [solaris,freebsd,perl,pugs,haskell] allbery at kf8nh.com
system administrator [openafs,heimdal,too many hats] allbery at ece.cmu.edu
electrical and computer engineering, carnegie mellon university    KF8NH

More information about the Haskell mailing list