[Haskell] cabal-upload build problem

Duncan Coutts duncan.coutts at worc.ox.ac.uk
Mon Feb 19 17:57:33 EST 2007

On Mon, 2007-02-19 at 22:39 +0000, Paul Johnson wrote:
> I want to upload a package to Hackage.  I tried installing cabal-upload, 
> but got the following error:
> ! Preprocessing executables for cabal-upload-0.2...
> ! Building cabal-upload-0.2...
> !
> ! src/CabalUpload.hs:7:7:
> !    Could not find module `Distribution.Compat.FilePath':
> !    it is hidden (in package Cabal-1.1.6)
> I tried "ghc-pkg expose Cabal-1.1.6" without success.
> I have ghc-6.6 installed on Linux (Fedora Core 6), including Cabal-1.1.6.

It was a mistake that that module was hidden in the version of Cabal
that shipped with ghc-6.6. If you install Cabal- or the current
darcs version 1.1.7 that should fix it.

BTW, make sure you don't unregister the Cabal 1.1.6 version you've
already got though because you have packages installed that depend on
that version. It's perfectly ok to have multiple versions installed at
once though.


More information about the Haskell mailing list