[Haskell] help needed to test new GLFW package

Paul L ninegua at gmail.com
Thu Dec 20 19:27:44 EST 2007

With the new Cabal 1.2, it's now possible to make platform dependent
C code compilation. So I've made available new version of GLFW that
follows standard Cabal installation steps, it's at:


Note that this is VERY experimental. Help is needed to test the
package on different combinations of GHC + OS platforms.

I've already tested it on Linux (i386 32bit) + GHC 6.8.2/6.6.1,
Windows XP and OS X 10.4 (Intel) + GHC 6.6 (with Cabal 1.2.2). I'll
appreciate feedbacks from GHC 6.8/6.6 on Linux (IA64), Windows Vista,
and OS X 10.5 (intel) or OS X (ppc).

If no major installation problem remains, I'm going to put it up on hackageDB.

Paul Liu

Yale Haskell Group

More information about the Haskell mailing list