[Haskell] Improvements to GHC
duncan.coutts at worc.ox.ac.uk
Thu Nov 17 09:29:12 EST 2005
On Thu, 2005-11-17 at 15:12 +0100, Fraser Wilson wrote:
> On 11/17/05, Joel Reymont <joelr1 at gmail.com> wrote:
> I vote for a separate namespace for record access functions.
> I agree, but ...
> My users now have to deal with tiGameID, blahBlahGameID, etc.
> they are all the same.
> To solve this problem I just made them all instances of a class with a
> gameId function. Still, not ideal.
That gives you a getter function but you would then need an extra setter
More information about the Haskell