[Haskell] readline troubles

Arjan van IJzendoorn afie at cs.uu.nl
Tue Apr 19 09:20:45 EDT 2005

Hello all,

Using GHCi 6.2.2 and HaXml-1.12 gives you the output below on Windows 
with Cygwin. I've seen this message on several other occasions and I 
finally managed to fix this using info at:

   (thank you, Sigbjorn!)

However, this is no trivial job and everyone who wants to compile a 
project using readline on Windows needs to patch this.

My question is: has this been solved in GHC 6.4 and if not, can this 
easily be solved? Maybe by including some version of readline in the 
Windows GHC installation?

Cheers, Arjan van IJzendoorn

----------------------- GHCi output

Loading package base ... linking ... done.
Loading package lang ... linking ... done.
Loading package haskell98 ... linking ... done.
Loading package concurrent ... linking ... done.
Loading package QuickCheck ... linking ... done.
Loading package readline ... linking ...
c:/apps/ghc/HSreadline.o: unknown symbol `_rl_redisplay_function'
ghc.exe: unable to load package `readline'

More information about the Haskell mailing list