[Haskell] RFC: DData in hierarchical libraries

ajb at spamcop.net ajb at spamcop.net
Wed Mar 10 22:06:01 EST 2004

G'day all.

Quoting JP Bernardy <jyp_7 at yahoo.com>:

> Would you prefix the function name with unsafe? I
> wonder what is the best way to do such a marking.

I would recommend not using that particular prefix.  At the moment,
I believe that "unsafe" is only used for functions which could
potentially cause a core dump if misused.

What we have here is a function whose domain is some subset of the
entire set of values which can be passed to it, but fails to check
this.  As a suggestion, how about calling functions like this
"uncheckedFoo", but also providing a "foo" which is checked?

Andrew Bromage

More information about the Haskell mailing list