Type class inference trouble

Ken Shan ken@digitas.harvard.edu
Thu, 15 Feb 2001 21:50:29 -0500

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On 2001-02-15T21:38:54-0500, Dylan Thurston wrote:
> > On Thu, Feb 15, 2001 at 02:37:09PM -0500, Ken Shan wrote:
> > >     test2 =3D apply [int 3] (apply [(+)::Int->Int->Int] [int 5])
> > What's strange is that when I tried this just now, the identical line at
> > the interpreter prompt returned the correct answer [8].  This is with
> > Hugs from February 2000; I'm about to download and try the new version.
> The same thing happens with the latest Hugs (February 2001).

I tried making things into functions, and that also helped.  I.e.,
instead of saying "test =3D ..." and "test2 =3D ...", I said "test _ =3D
=2E.." and "test2 _ =3D ..."; both worked.

Can someone please explain this behavior?  I don't understand type
classes very well...

Edit this signature at http://rodimus.digitas.harvard.edu/cgi-bin/ken/sig
"The day Microsoft makes something that doesn't suck is probably the day
                   they start making vacuum cleaners" - Ernst Jan Plugge

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.0.4 (GNU/Linux)
Comment: For info see http://www.gnupg.org