three syntax-sugar proposals
Bulat Ziganshin
bulat.ziganshin at gmail.com
Sat Oct 14 11:19:32 EDT 2006
Hello haskell-prime,
1. allow to use '_' in number literals. its used in Ruby and i found
that this makes long number literals much more readable. for example
maxint = 2_147_483_648
2. allow to use string literals in patterns as head of matched list:
optionValue ("kb"++n) = read n * 2^10
optionValue ("mb"++n) = read n * 2^20
this syntax already used in Erlang
3. writing kinds is very rare task, but i still don't like to count
number of stars in something like '* -> * -> * -> *'. i think that
representing this as '****' will be more readable
--
Best regards,
Bulat mailto:Bulat.Ziganshin at gmail.com
More information about the Haskell-prime
mailing list