Proposal for stand-alone deriving declarations?

Brian Smith brianlsmith at
Sun Oct 8 12:22:59 EDT 2006

On 10/6/06, Björn Bringert <bringert at> wrote:
> John Hughes wrote:
> > deriving (Eq Foo, Ord Foo)
> >
> > instead of
> >
> > deriving (Eq, Ord) for Foo
> >
> > I find the former syntax clearer and more readable, actually.
> >
> > John
> I'll implement this syntax instead and then write up a Haskell' proposal.

I am sure that it was already argued at great length, but I think it is
wrong to start the declaration with "deriving." I believe that "derive
instance" fits much better into the language. I understand the desire to
avoid adding new keywords but I think that something along the lines of what
was done for "for" could be done here for "derive."

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Haskell-prime mailing list