<div dir="ltr">I wonder if you have a cached Setup.hs somewhere under ~/.cabal that's out of date (i.e. uses and older Cabal). You can try -v2 or -v3 to get some more information. In particular look for mentions of older Cabal versions.</div><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Jan 13, 2015 at 5:53 AM, Ozgur Akgun <span dir="ltr"><<a href="mailto:ozgurakgun@gmail.com" target="_blank">ozgurakgun@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div class="gmail_extra"><span class=""><br><div class="gmail_quote">On 13 January 2015 at 13:43, Ozgur Akgun <span dir="ltr"><<a href="mailto:ozgurakgun@gmail.com" target="_blank">ozgurakgun@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><div>To be precise, I ran the following and can use --disable-profiling with ghc-7.6.3 now.</div><div></div></blockquote></div><br></span>I spoke too early.</div><div class="gmail_extra"><br></div><div class="gmail_extra">Weird problem, running `cabal install --disable-profiling -j1` works, but using a higher number of cores I get the same error during cabal configure. Here is what I did.</div><span class=""><div class="gmail_extra"><br></div><div class="gmail_extra"><br></div><div class="gmail_extra">$ ghc -V<br></div><div class="gmail_extra">The Glorious Glasgow Haskell Compilation System, version 7.6.3</div><div class="gmail_extra">$ cabal -V</div><div class="gmail_extra">cabal-install version 1.22.0.0</div><div class="gmail_extra">using version 1.22.0.0 of the Cabal library</div></span><div class="gmail_extra">$ cabal install -j3 --disable-profiling mtl</div><div class="gmail_extra">Resolving dependencies...</div><span class=""><div class="gmail_extra">Configuring transformers-0.4.2.0...</div><div class="gmail_extra">Failed to install transformers-0.4.2.0</div></span><div class="gmail_extra">Build log [...]:</div><span class=""><div class="gmail_extra">unrecognized 'configure' option `--disable-profiling'</div><div class="gmail_extra">cabal: Error: some packages failed to install:</div></span><div class="gmail_extra">mtl-2.2.1 depends on transformers-0.4.2.0 which failed to install.</div><span class=""><div class="gmail_extra">transformers-0.4.2.0 failed during the configure step. The exception was:</div><div class="gmail_extra">ExitFailure 1</div></span><div class="gmail_extra">$ cabal install -j1 --disable-profiling mtl</div><div class="gmail_extra">(This works fine.)</div><div class="gmail_extra"><br></div><div class="gmail_extra">Am I missing something?<span class="HOEnZb"><font color="#888888"><br></font></span></div><span class="HOEnZb"><font color="#888888"><div class="gmail_extra"><br></div><div class="gmail_extra">Ozgur</div><div class="gmail_extra"><br></div><div class="gmail_extra"><div></div>
</div></font></span></div>
<br>_______________________________________________<br>
Haskell-Cafe mailing list<br>
<a href="mailto:Haskell-Cafe@haskell.org">Haskell-Cafe@haskell.org</a><br>
<a href="http://www.haskell.org/mailman/listinfo/haskell-cafe" target="_blank">http://www.haskell.org/mailman/listinfo/haskell-cafe</a><br>
<br></blockquote></div><br></div>