<div dir="ltr"><div class="gmail_extra"><br><div class="gmail_quote">On 13 January 2015 at 13:00, Erik Hesselink <span dir="ltr"><<a href="mailto:hesselink@gmail.com" target="_blank">hesselink@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><div id=":217" class="" style="overflow:hidden">I've had this problem as well. I think the issue is that 'cabal' now<br>
expects '--disable-profiling', but if you have a custom Setup.hs, it<br>
can be compiled with an older version of the Cabal library, and then<br>
it expects '--disable-executable-profiling' again. What is the output<br>
of 'ghc-pkg list Cabal'?<br></div></blockquote></div><div class="gmail_extra"><br></div><div class="gmail_extra">I have 3 versions of Cabal as reported by "ghc-pkg list Cabal".</div><div class="gmail_extra">Cabal-1.16.0 in the global package db, Cabal-1.18.1 and Cabal-1.20.0.0 in the user db.</div><div class="gmail_extra">Do you think I should be hiding the old ones?</div><div class="gmail_extra"><br></div>Ozgur
</div><div class="gmail_extra"><br></div></div>