<div dir="ltr"><div>A recent change in cabal-install's command line interface seems not to be compatible with ghc-7.6.3.</div><div><br></div>cabal-install-1.22.0.0 doesn't like --disable-executable-profiling as a command line option any more. (I could only find this related to this change: <a href="https://github.com/haskell/cabal/pull/2286">https://github.com/haskell/cabal/pull/2286</a>)<div><div><br></div><div>$ cabal install --disable-executable-profiling<div>cabal: unrecognized 'install' option `--disable-executable-profiling'</div><div><br></div><div>I try --disable-profiling instead.</div><div><br></div><div>$ cabal install transformers --disable-profiling -j3</div><div>Resolving dependencies...</div><div>Notice: installing into a sandbox located at [snip]</div><div>Configuring transformers-0.4.2.0...</div><div>Failed to install transformers-0.4.2.0</div><div>Build log [snip]:</div><div>unrecognized 'configure' option `--disable-profiling'</div><div>cabal: Error: some packages failed to install:</div><div>transformers-0.4.2.0 failed during the configure step. The exception was:</div><div>ExitFailure 1</div><div><br></div><div>Using the following versions of cabal and ghc.</div><div><br></div><div>$ cabal -V</div><div>cabal-install version 1.22.0.0</div><div>using version 1.22.0.0 of the Cabal library</div><div>$ ghc -V</div><div>The Glorious Glasgow Haskell Compilation System, version 7.6.3</div><div><br></div><div><div>--disable-profiling works fine with ghc-7.8.3, this is only a problem with 7.6.3.</div></div><div><br></div><div><br></div><div>PS: transformers is only a dependency of an executable I am trying to build. But this happens with all the other dependencies as well.</div><div><br></div><div><br></div><div><br></div>-- <br><div class="gmail_signature">Ozgur Akgun</div>
</div></div></div>