[Haskell-cafe] Building Asterius locally

Hilco Wijbenga hilco.wijbenga at gmail.com
Sat Jun 6 20:34:37 UTC 2020

Hi all,

Has anyone tried building Asterius
(https://asterius.netlify.app/building.html)? I'm stuck because
GHC/GCC can't find binaryen-c.h which is available in
/usr/include/binaryen. If I add a symbolic link in /usr/include to
binaryen-c.h then this one is found but the next one isn't. Obviously,
I don't want to link to every binaryen header file like that.

binaryen   > /tmp/stack-b6b7026e470b48c5/binaryen-
binaryen   >     fatal error: binaryen-c.h: No such file or directory
binaryen   >        1 | #include <binaryen-c.h>
binaryen   >          |         ^~~~~~~~~~~~~~
binaryen   >   |
binaryen   > 1 | #include <binaryen-c.h>
binaryen   >   |         ^
binaryen   > compilation terminated.
binaryen   > `gcc' failed in phase `C Compiler'. (Exit code: 1)

I've tried adding include-dirs: /usr/include/binaryen in various
places (in package.yaml) but that did not make any difference.

In short, how do I make sure /usr/include/binaryen is part of the
search path for C header files?


More information about the Haskell-Cafe mailing list