[Haskell-cafe] ANN: stack-1.7.1

Viktor Dukhovni ietf-dane at dukhovni.org
Sat Apr 28 22:14:03 UTC 2018

> On Apr 28, 2018, at 5:53 PM, Emanuel Borsboom <manny at fpcomplete.com> wrote:
> This should be fixed now.  The GHC 8.4.x bindists weren't under the right OS key in the GHC setup metadata.  That said, this shouldn't behave any differently on stack-1.7.x than it did with stack-1.6.x.

Yes, the same problem with stack 1.6, I just updated stack and tried the snapshot at the same time.

> I'm curious if this will work for you though.  I just tried it on a FreeBSD 11 VM and GHC 8.4.2 failed stack's post-install sanity check with a bunch of errors

I'll let you know.  For some reason running "strip" on the various ".a" files extracted from the archive is taking a very long time...  For example, still running as I write:

$ ps -wwww -o pid,etime,args -p $(pgrep strip)
72558   05:49 strip --strip-unneeded /usr/home/viktor/.stack/programs/x86_64-freebsd/ghc-8.4.2/lib/ghc-8.4.2/Cabal-


More information about the Haskell-Cafe mailing list