[Haskell-cafe] Haskell plugin dynamic linking issue

Lana Black lanablack at amok.cc
Thu Apr 13 21:23:30 UTC 2017

On 13/04/17 18:42, Albert Y. C. Lai wrote:
> On 2017-04-11 03:20 AM, Lana Black wrote:
>>> cabal configure
>> Resolving dependencies...
>> Configuring cabal-bug-0.1...
>> cabal: Missing dependency on a foreign library:
>> * Missing C library: HSrts-ghc8.0.2
>> This problem can usually be solved by installing the system package that
>> provides this library (you may need the "-dev" version). If the
>> library is
>> already installed but in a non-standard location then you can use the
>> flags
>> --extra-include-dirs= and --extra-lib-dirs= to specify where it is.
>> However, that doesn't prevent cabal build from succeeding, and now I
>> have a shared library linked to RTS.
> [...]
>> However, if I run cabal build without calling cabal configure first, the
>> latter fails and the build process is stopped at that point. This also
>> prevents me from building my project with stack.
> Here is the thing. I cannot reproduce either outcome.

I dug a bit further, and it looks like the cabal configure error is
somehow related to Gentoo, since I'm only able to reproduce it there.
Otherwise the solution you linked works perfectly.

More information about the Haskell-Cafe mailing list