[Haskell-cafe] Passing a cabal flag to stack

Rustom Mody rustompmody at gmail.com
Sat Jul 16 03:22:21 UTC 2016

I’ve been trying to compile hoodle following the instructions in the readme:

Went further than year or two earlier when attempt got mired in cabal-hell

This time stack build went through (after a couple of deb packages needing

Now I get this error on trying to run

GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is
not supported

Asking on the hoodle mailing list I was told that one has to build poppler
with option -fgtk3

Where/How to give that?
Looking at https://github.com/commercialhaskell/stack/issues/191
I tried the following:
1. Delete every file/directory under .stack-work that has the word poppler
2. stack build poppler --flag gtk:gtk3
3. stack build

Seems to have built
Ok I get the same warning that stack seems to be generally giving — dozens
of them  — viz
No packages found in snapshot which provide a "gtk2hsC2hs" executable,
which is a build-tool dependency of "glib"
Missing build-tools may be caused by dependencies of the build-tool being
overridden by extra-deps.
This should be fixed soon - see this issue

But thereafter stack exec hoodle
results in the same error.

So whats the official way of putting the -fgtk3 flag into stack?
Any other suggestions?

stack first tried from deb; then redone from stack website
$ ghc --version
The Glorious Glasgow Haskell Compilation System, version 7.10.3

ubuntu 16.4 (if that matters)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.haskell.org/pipermail/haskell-cafe/attachments/20160716/86c79718/attachment.html>

More information about the Haskell-Cafe mailing list