[Haskell-cafe] [Haskell] I repeat my Question becaue I not really sure to do it right

Jacco Krijnen jaccokrijnen at gmail.com
Mon Aug 29 09:05:35 UTC 2016


! Please note that Leksah is currently quite unstable. There's quite some
known bugs and rough edges so I'd recommend waiting for the next official
release.

The only reliable way to build it on Linux right now is from source/github
with cabal-install >= 1.24 (see
https://github.com/leksah/leksah#building-from-source). We're planning to
look into .deb installers to make the installation on Linux easier, but
there is limited man power and it is not really high-priority.

Jacco

2016-08-28 23:36 GMT+02:00 Ivan Lazar Miljenovic <ivan.miljenovic at gmail.com>
:

> On 28 August 2016 at 23:15,  <CCUTM at web.de> wrote:
> > Hello it is possible that this is the solution.
> > But I don't know how I can istall it.
>
> See the Ubuntu section here: http://www.leksah.org/download.html
>
> >
> > Gesendet: Sonntag, 28. August 2016 um 15:07 Uhr
> > Von: "Ivan Lazar Miljenovic" <ivan.miljenovic at gmail.com>
> > An: CCUTM at web.de
> > Betreff: Re: Re: [Haskell] I repeat my Question becaue I not really sure
> to
> > do it right
> > Do you have the -dev libraries installed for gtk, glib, etc.?
> >
> > Or is there a gtk2hs package available for Ubuntu?
> >
> > On Sun, 28 Aug 2016, 11:05 PM <CCUTM at web.de> wrote:
> >>
> >> I'm seem rubish,
> >> but exactly that have I do
> >> And I have at first install cabal.
> >> But this is comming:
> >>
> >> Resolving dependencies...
> >> Configuring glib-0.13.4.0...
> >> Building glib-0.13.4.0...
> >> Failed to install glib-0.13.4.0
> >> Build log ( /home/thomas/.cabal/logs/glib-0.13.4.0.log ):
> >> [1 of 1] Compiling Main             (
> >> /tmp/cabal-tmp-4585/glib-0.13.4.0/dist/setup/setup.hs,
> >> /tmp/cabal-tmp-4585/glib-0.13.4.0/dist/setup/Main.o )
> >> Linking /tmp/cabal-tmp-4585/glib-0.13.4.0/dist/setup/setup ...
> >> Configuring glib-0.13.4.0...
> >> Building glib-0.13.4.0...
> >> Preprocessing library glib-0.13.4.0...
> >> /usr/bin/ld: dist/build/System/Glib/StoreValue_hsc_make.o: Die
> Umlagerung
> >> von
> >> dist/build/System/Glib/StoreValue_hsc_make.o: error adding symbols:
> >> Ung├╝ltiger Wert
> >> collect2: error: ld returned 1 exit status
> >> linking dist/build/System/Glib/StoreValue_hsc_make.o failed (exit code
> 1)
> >> command was: /usr/bin/gcc dist/build/System/Glib/StoreValue_hsc_make.o
> >> dist/build/System/Glib/StoreValue_hsc_utils.o -o
> >> dist/build/System/Glib/StoreValue_hsc_make -fno-PIE
> -fno-stack-protector
> >> -lgobject-2.0 -lglib-2.0
> >> -L/home/thomas/.cabal/lib/x86_64-linux-ghc-7.10.3/utf8-string-1.0.1.1-
> L8eKHa7Iv9q7FVKUYW6u4b
> >> -Wl,-R,/home/thomas/.cabal/lib/x86_64-linux-ghc-7.10.3/
> utf8-string-1.0.1.1-L8eKHa7Iv9q7FVKUYW6u4b
> >> -L/home/thomas/.cabal/lib/x86_64-linux-ghc-7.10.3/text-1.2.
> 2.1-HmqVQnZSpjaC156ABqPhne
> >> -Wl,-R,/home/thomas/.cabal/lib/x86_64-linux-ghc-7.10.3/text-1.2.2.1-
> HmqVQnZSpjaC156ABqPhne
> >> -L/usr/lib/ghc/binar_3uXFWMoAGBg0xKP9MHKRwi
> >> -Wl,-R,/usr/lib/ghc/binar_3uXFWMoAGBg0xKP9MHKRwi
> >> -L/usr/lib/ghc/conta_2C3ZI8RgPO2LBMidXKTvIU
> >> -Wl,-R,/usr/lib/ghc/conta_2C3ZI8RgPO2LBMidXKTvIU
> >> -L/usr/lib/ghc/bytes_6VWy06pWzJq9evDvK2d4w6
> >> -Wl,-R,/usr/lib/ghc/bytes_6VWy06pWzJq9evDvK2d4w6
> >> -L/usr/lib/ghc/deeps_6vMKxt5sPFR0XsbRWvvq59
> >> -Wl,-R,/usr/lib/ghc/deeps_6vMKxt5sPFR0XsbRWvvq59
> >> -L/usr/lib/ghc/array_67iodizgJQIIxYVTp4emlA
> >> -Wl,-R,/usr/lib/ghc/array_67iodizgJQIIxYVTp4emlA
> >> -L/usr/lib/ghc/base_HQfYBxpPvuw8OunzQu6JGM
> >> -Wl,-R,/usr/lib/ghc/base_HQfYBxpPvuw8OunzQu6JGM
> >> -L/usr/lib/ghc/integ_2aU3IZNMF9a7mQ0OzsZ0dS
> >> -Wl,-R,/usr/lib/ghc/integ_2aU3IZNMF9a7mQ0OzsZ0dS -lgmp
> >> -L/usr/lib/ghc/ghcpr_8TmvWUcS1U1IKHT0levwg3
> >> -Wl,-R,/usr/lib/ghc/ghcpr_8TmvWUcS1U1IKHT0levwg3 -L/usr/lib/ghc/rts
> >> -Wl,-R,/usr/lib/ghc/rts -lm -lrt -ldl -lffi
> >> cabal: Error: some packages failed to install:
> >> ghcjs-dom-0.2.4.0 depends on glib-0.13.4.0 which failed to install.
> >> gio-0.13.3.0 depends on glib-0.13.4.0 which failed to install.
> >> glib-0.13.4.0 failed during the building phase. The exception was:
> >> ExitFailure 1
> >> gtk3-0.14.5 depends on glib-0.13.4.0 which failed to install.
> >> gtksourceview3-0.13.3.0 depends on glib-0.13.4.0 which failed to
> install.
> >> jsaddle-0.3.0.3 depends on glib-0.13.4.0 which failed to install.
> >> leksah-0.15.2.0 depends on glib-0.13.4.0 which failed to install.
> >> leksah-server-0.15.2.0 depends on glib-0.13.4.0 which failed to install.
> >> ltk-0.15.0.5 depends on glib-0.13.4.0 which failed to install.
> >> pango-0.13.3.0 depends on glib-0.13.4.0 which failed to install.
> >> vcsgui-0.1.3.0 depends on glib-0.13.4.0 which failed to install.
> >> webkitgtk3-0.14.2.0 depends on glib-0.13.4.0 which failed to install.
> >> webkitgtk3-javascriptcore-0.13.2.0 depends on glib-0.13.4.0 which
> failed
> >> to
> >> install.
> >>
> >> Please can you help me!!?
> >>
> >>
> >> Gesendet: Sonntag, 28. August 2016 um 14:50 Uhr
> >>
> >> Von: "Ivan Lazar Miljenovic" <ivan.miljenovic at gmail.com>
> >> An: CCUTM at web.de
> >> Cc: "Haskell List" <haskell at haskell.org>
> >> Betreff: Re: [Haskell] I repeat my Question becaue I not really sure to
> do
> >> it right
> >> On 28 August 2016 at 22:40, <CCUTM at web.de> wrote:
> >> > This is Leksah http://leksah.org/
> >> > Please excuse my false name for it
> >> > And the Question is why can I install it.
> >>
> >> What error messages do you have when you try?
> >>
> >> From here, this is what you need to do:
> >> https://github.com/leksah/leksah/wiki/download
> >>
> >> > cabal install gtk2hs-buildtools
> >>
> >> > cabal install leksah
> >>
> >>
> >>
> >> >
> >> > excuse me.
> >> > Mungo1981
> >> >
> >> > Gesendet: Sonntag, 28. August 2016 um 13:49 Uhr
> >> > Von: "Ivan Lazar Miljenovic" <ivan.miljenovic at gmail.com>
> >> > An: CCUTM at web.de
> >> > Cc: "Haskell List" <haskell at haskell.org>
> >> > Betreff: Re: [Haskell] I repeat my Question becaue I not really sure
> to
> >> > do
> >> > it right
> >> > On 28 August 2016 at 20:43, <CCUTM at web.de> wrote:
> >> >> Ok Haskell is good.
> >> >> Ok Laska is great.
> >> >> And my Ubuntu Studio ist rubish
> >> >> So I try to install Laska on Ubuntu Studio
> >> >> But when I do this, i will get a long list of dependecies
> >> >> which could not reallise
> >> >> So I not know what should I do
> >> >
> >> > Which question?
> >> >
> >> > What is Laska that you're having trouble installing it?
> >> >
> >> >>
> >> >> Mungo1981
> >> >>
> >> >> _______________________________________________
> >> >> Haskell mailing list
> >> >> Haskell at haskell.org
> >> >> http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell
> >> >>
> >> >
> >> >
> >> >
> >> > --
> >> > Ivan Lazar Miljenovic
> >> > Ivan.Miljenovic at gmail.com
> >> > http://IvanMiljenovic.wordpress.com
> >> >
> >> > _______________________________________________
> >> > Haskell mailing list
> >> > Haskell at haskell.org
> >> > http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell
> >> >
> >>
> >>
> >>
> >> --
> >> Ivan Lazar Miljenovic
> >> Ivan.Miljenovic at gmail.com
> >> http://IvanMiljenovic.wordpress.com
>
>
>
> --
> Ivan Lazar Miljenovic
> Ivan.Miljenovic at gmail.com
> http://IvanMiljenovic.wordpress.com
> _______________________________________________
> Haskell-Cafe mailing list
> To (un)subscribe, modify options or view archives go to:
> http://mail.haskell.org/cgi-bin/mailman/listinfo/haskell-cafe
> Only members subscribed via the mailman list are allowed to post.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.haskell.org/pipermail/haskell-cafe/attachments/20160829/a35d9c5b/attachment.html>


More information about the Haskell-Cafe mailing list