[Haskell-cafe] Weird reachability issue with haskell.org my my Italian ISP (fastweb)

Alfredo Di Napoli alfredo.dinapoli at gmail.com
Fri Jan 2 11:41:09 UTC 2015

I ended up using a machine running privoxy (using aws or similar) and that works, but I'm not sure I want to pay for the idiocity of my ISP.

Happy new year all, anyway.

Alfredo Di Napoli

> On 01/gen/2015, at 11:53, Giacomo Cosenza <mimmo.cosenza at gmail.com> wrote:
> Same thing here too. few weeks ago there were no problems.
> mimmo
>> On Tuesday, December 30, 2014 8:26:15 PM UTC+1, george watkins wrote:
>> Lo stesso, same thing here .
>> I am using this mirror if for hoogle it can help https://www.fpcomplete.com/hoogle.
>> At the beginnig i thought it was my dns improperly configured or something wrong with my network
>> Il giorno martedì 23 dicembre 2014 18:55:00 UTC+1, Alfredo Di Napoli ha scritto:
>>> Hello Cafè,
>>> let me start with the email I've sent to Rackspace, which will help you understand the context:
>>>> Hi there!
>>>> I'm trying to understand how come I can't reach www.haskell.org from my ISP here in Italy (fastweb). In order to troubleshoot the issue, I tried dig on it, revealing it's hosted by you:
>>>> dig haskell.org
>>>> ; <<>> DiG 9.8.3-P1 <<>> haskell.org
>>>> ;; global options: +cmd
>>>> ;; Got answer:
>>>> ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63629
>>>> ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
>>>> ;haskell.org.INA
>>>> haskell.org. 299 IN A
>>>> ;; Query time: 139 msec
>>>> ;; SERVER:
>>>> ;; WHEN: Tue Dec 23 18:33:00 2014
>>>> ;; MSG SIZE  rcvd: 45
>>>> Trying a whois reveals the subnet is the entire one:
>>>> Rackspace Cloud Servers RACKS-8-1387376775861482 (NET-23-253-80-0-1) -
>>>> Rackspace Hosting RACKS-8-NET-15 (NET-23-253-0-0-1) -
>>>> If I try to ping the IP directly, it obviously doesn't work, so I have tried contiguous IP addresses in the same subnet to see if the subnet itself was reachable at all.. trying indeed worked! It resolved to
>>>> http://www.papamurphys.com/
>>>> This means my ISP can reach that subnet, but doesn't explain why it can't connect to 
>>> That's very weird indeed, as every other website is reachable, only haskell.org is not! How funny my fate is! I'm one of the few Haskellers in Italy and yet I cannot access the website.. perhaps is the consequence of "Avoid success at all costs"?? :) :)
>>> Jokes aside, do you guys know (I'm asking mainly to Austin here) if rackspace uses some weird setup for their website deployment or if haskell.org is hosted "the usual way" and listening on port 80?
>>> Thanks in advance for the 1% who is concerned, for all the other 99%, merry Xmas ;)
>>> Alfredo 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/haskell-cafe/attachments/20150102/ffdc8467/attachment.html>

More information about the Haskell-Cafe mailing list