[Haskell-cafe] Trouble installing ghc on CentOS 6

Lyle Kopnicky lists at qseep.net
Mon Dec 14 23:34:21 UTC 2015

Hi folks,

I'm trying to install the 64-bit generic Linux distribution of ghc-7.10.3
on CentOS 6, as a non-privileged user in my home dir.

I've unpacked the files, and I ran ./configure, but it told me it couldn't
find libgmp.so.3. I searched for and found that library on the system.
Looking at the help for ./configure, I saw the --with-gmp-libraries option,
so I tried again with that, but it still can't seem to find the file:

$ ./configure --prefix=/home/kopnicky/ghc --with-gmp-libraries=/usr/lib64
checking for path to top of build tree...
utils/ghc-pwd/dist-install/build/tmp/ghc-pwd: error while loading shared
libraries: libgmp.so.3: cannot open shared object file: No such file or
configure: error: cannot determine current directory

Strange, because that library is definitely there in /usr/lib64. Any
thoughts on what I can try next?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.haskell.org/pipermail/haskell-cafe/attachments/20151214/82e9def5/attachment.html>

More information about the Haskell-Cafe mailing list