[Haskell-cafe] an idea for modifiyng data/newtype syntax: use `::=` instead of `=`

Alexey Muranov alexey.muranov at gmail.com
Sat Aug 8 12:54:22 UTC 2015

On 8 août 2015, at 14:40, Oliver Charles <ollie at ocharles.org.uk> wrote:
> There is reasonable reasoning here, but what you suggest breaks almost all Haskell code that has ever been written. Sounds like an idea better suited to the design of a new language :)
Maybe adding a language pragma or having both would avoid break any code?
> Also, i think you need the newtype/data distinction as I believe they are operationally different wrt laziness.
Maybe keeping the `newtype` keyword would suffice?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.haskell.org/pipermail/haskell-cafe/attachments/20150808/36597bbe/attachment.html>

More information about the Haskell-Cafe mailing list