[Haskell-cafe] Cannot run GHC-7.10.1 tests

Bernhard Herzog bh at intevation.de
Thu Apr 30 10:55:25 UTC 2015

On 29.04.2015, Jeremy Henty wrote:
> But since you suggested it, I tried running all the test commands from
> within  the  ghc-7.10.1/testsuite directory  and  they  all failed  as
> follows:
>    mk/boilerplate.mk:168: mk/ghcconfig_data_build.d_6.8_ghc-7.10.1_inplace_bin_ghc-stage2.mk: No such file or directory
>    ./mk/ghc-config "/data/build.d/6.8/ghc-7.10.1/inplace/bin/ghc-stage2"
> >"mk/ghcconfig_data_build.d_6.8_ghc-7.10.1_inplace_bin_ghc-stage2.mk"; if [ $? != 0 ]; then 
rm -f "mk/ghcconfig_data_build.d_6.8_ghc-7.10.1_inplace_bin_ghc-stage2.mk"; exit 1; fi 
>    /bin/sh: ./mk/ghc-config: cannot execute binary file
>    make: *** [mk/ghcconfig_data_build.d_6.8_ghc-7.10.1_inplace_bin_ghc-stage2.mk] Error 1

Just tried this myself. I get very similar errors. The reason is,
AFAICT, that the testsuite tarball contains some build-artifacts,
particularly some binaries. A "make clean" in the testsuite directory
before running the tests helps.



More information about the Haskell-Cafe mailing list