[Haskell-cafe] Haskell-cafe] Yesod can't build on 64 bit 7.8.2 Windows

Stuart Mills smills at systems-dev.com
Thu May 22 19:07:41 UTC 2014

Apparently in going to Mingw 64 the packages "system-fileio" and 
"unix-compat" no longer compiled because some Windows routines were not 
available in their expected "names".  I reported the issues and John 
Milikin quickly patched "system-fileio" (thanks John, if you're listening).

The unix-compat issue is still outstanding (not sure if it's still being 
maintained), but I was able to patch it by adding underscores to 
elements like "snprintf".  ( _snprintf works,  _stat instead of stat,  
etc.)   These were the same types of changes that worked for 
system-fileio. Note that this approach may break Win32.

The next issue is when linking with yaml (ghc.exe: panic!).    This was 
reported as a GHC bug 2 weeks ago (#9080) by maun, who was trying to 
build GHCJS.  I get the exact same error in building Yesod.

Because of Yesod, I think #9080 should be promoted to high priority, and 
it would be great if someone could bring unix-compat up to date.


More information about the Haskell-Cafe mailing list