[Haskell-cafe] Uploading to hackage fails: bad file names in tarball

Arie Peterson ariep at xs4all.nl
Mon Jun 16 08:44:30 UTC 2014

Since some time, I have been unable to upload packages to Hackage, via either 
the 'cabal upload' command, or using the web form.

The error message it gives is this:

==== ✂ ====
Hackage username: AriePeterson
Hackage password: 
Uploading dist/np-linear-
Error: dist/np-linear- 400 Bad Request
Error: Invalid package

Invalid windows file name in tar archive: "np-linear-\\src\\Aux.hs".
For portability, hackage requires that file names be valid on both Unix and
Windows systems, and not refer outside of the tarball.
==== ✂ ====

The tarball is created by 'cabal sdist':
cabal-install version
using version of the Cabal library.

I also installed the newest cabal-install, on another machine, but this did 
not help (same error).

I also tried to create a tarball by hand, using 'tar --format=ustar', but this 
again resulted in the same error message.

By the way, I'm on linux, not Windows, so it is not clear how the backslashes 
get in the file names.

What could be going on?

More information about the Haskell-Cafe mailing list