[Haskell-cafe] Horray, a ghc bug!

Jason Dagit dagitj at gmail.com
Mon Oct 21 19:58:49 UTC 2013

On Mon, Oct 21, 2013 at 12:42 PM, Andreas Abel <andreas.abel at ifi.lmu.de>wrote:

> Hi, I tried the 64bit binary packages from
>   haskell.org/ghc
> but I got a complaint that
>   libgmp.so.3
> is not found on my system (and locate did not reveal it).  I have several
> of these libgmp.so, but apparently not the right one
> locate libgmp.so

It's a side effect of the distro that these packages are built on. They
have a libgmp.so.3 that configure finds/uses, but I think most distros no
longer install that. Often times they do have a suitable libgmp and a
symlink can fix the issue.

What I do when I run into this is something roughly like this:

1. Run ldd on the executable that is complaining  (alternatively, you can
use readelf -d), to find out what shared object is not being loaded
correctly and get a hint of the expected path. If you can't figure out the
path, then assume it will be the same path used by other .so files.

2. Find a close match, such as the ones you found with locate.

3. (Optional) install the necessary package because no close match is there.

4.  Create a symlink in the right place.

Building from source is usually easier :)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/haskell-cafe/attachments/20131021/7c04124c/attachment.html>

More information about the Haskell-Cafe mailing list